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Installing Susanna

To install Susanna run the SETUP.EXE you have received.

The installation program will ask where you want to install Susanna. Enter a directory address and press
Enter or accept the usual Susanna installation directory c:\susanna by pressing just Enter.
Note: if you want to choose your own directory enter only a first level directory address such as d:\mysus
or c:\susu. Do not enter, say, c:\myfiles\susu etc..

Please note that allthough most manual pictures are from Bryce 4 Susanna works also with Bryce 5.

PLEASE READ THE ENTIRE MANUAL. YOU WON’T GET ANYWHERE IF YOU DON’T.

Licence

You are granted a personal, non-transferable and non-exclusive licence to use this program and it’s
documentation. The program must be used by only one person at one time. A single user can use the
program simultaneously on a number of computers so long as no other person uses it at the same time
or has access to the other computers where it has been installed. This is to facilitate creating animation
with multiple computers.

You may not copy the program or its documentation in any form except to make one backup copy solely
for backup purposes or above mentioned situation.

Disclaimer

We believe the program performs it duties as described in this manual but we cannot guarantee it to
work in any fashion or form with any computer or software configuration. This software is provided as-is
without any warranty of any kind, either expressed or implied, including but not limited to the implied
warranties of merchantability and fitness for a particular purpose. You assume entire risk as it applies to
the quality and performance of the program and documentation. Should the program prove defective you
assume the entire cost of all necessary servicing repair or correction.

Copyright and contact detail

Susanna is a trademark of

Soft Systems Ltd
PL 51
02151 Espoo
Finland

posti@datamike.com
fax: +358-0-4584369

Trademarks

Poser is a registered trademark of Curious Labs. Bryce 4 is a registered trademark of Corel. All other
trademarks belong to their respective owners.

Thank you for choosing Susanna!
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Creating a Poser Animation File Sequence

Susanna works with Poser created OBJ animation file sequence. You may also you a compatible OBJ
file sequence created by another program. You can also create a multiple character animation in Poser
and then export them all to
Bryce for rendering.

Let’s create a simple Poser
animation:

1. Start Poser. You get the
default figure.

2. Choose Animation >
Animation Setup.

3. Animation setup window
pops up. For starters we’ll
create a default 30 frame
animation. Enter values as
shown and press OK.

4. Now pose the figure as
desired. Add props and
choose materials. Refer to
Poser manual how to do this.
We advise you to go easy at
this point even if you are an
experienced poser. There
are some helpful and
important tips described later
in Poser Animation Tips.

5. When you are ready go to
the first frame (important).
You can do this by clicking
the vcr-style button on
left-bottom corner (5a). Click
the handle on the right (5b)
and click Props. Double click
the Square.

6. A square appears on the
floor, often at the feet of the
figure. Rotate it 90 or -90
percent using the xrotate
dial. The square may appear
to vanish but rest assured it’s
there. It stays there for the
duration of the animation. Do
not change it (unless you are
creating something special).
This square tells Susanna
the location of floor when the
poser is imported to Bryce. It
also tells where the figure is
positioned in a Poser scene.
It is also important that you
create the square when you
have included all props and
characters in the Poser
animation. We’ll get back to
this later. Also it is important that the square wide enough
the “cover” the whole poser even with hands (or if you have
an animal tail, fins, flippers, whatever) outstreched.

7. Ok. So far so good. Now that everything is ready choose
File > Export > Wavefront OBJ. The program will ask the
export range. Select Multiframe export and press OK.
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8. A hierarchy selection windows comes up. Check all
items but not ground or universe. If you have paths don’t
check them. Make sure that you check the square further
down in the item tree. If all is fine the square should be the
last item in the item tree. Lastly press OK.

10. Poser now ask the directory and file name. Select a

suitable directory. A good idea is to create a new directory
such as c:\anim for your poser animation files. For a file
name select a short file name such as man, abcd, run, etc.
having maximum of four letters. Poser will then make a
sequence of files man_1.obj, man_2.obj, etc.. Every file in
the resulting file sequence must comply to short file name
convention (maximum of eight letters + dot and three more
letters) which Susanna uses. So to complete the export
press Save.

11. Your poser figures may use bump maps, materials,
transparencies, textures etc.. A copy of these must be available at the same directory as your poser
created animation OBJ files. To make things simple just copy all files in your Poser directory
c:\Poser4\Runtime\Textures\Poser 3 textures and c:\Poser4\Runtime\Textures\Poser 4 textures to your
designated Poser animation directory, say, c:\anim.

Now you are ready on the Poser side.
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Poser Animation Tips

Preventing Levitation and going through the floor

If you make your animation by choosing poses from pose menu make sure you’re figure is dropped to
the floor. Otherwise you get a figure that appears to levitate when animated in Bryce! Many ready-made
poses elevate the figure a little. So use the Figure > Drop to floor just to make sure.

Walks and runs

If your animations consists of a runs or a walks you don’t have to create a path for it. The path is
discarded when imported to Bryce.

It is often unnecessary to create a walk sequence lasting more than just one full pair of step: both legs
complete a step. Those step can be repeated over and over with Susanna in Bryce. Futhermore Poser
often creates an extra frame when it completes a walk or run.

Here’s how you create a simple walk that can be repeated ad
nauseum:

1. Start Poser. You get the default figure.

2. Choose Animation > Animation Setup.

3. Animation setup window pop up. For starters we’ll just create
a default 30 frame animation (actually a 29 frame) that lasts just
one second. Enter values as shown and press OK. One second
is about the time a person completes a step.

4. Choose Window > Walk Designer. A walk
designer window pops up. Here you can create
different styles of walk and runs. test some
styles if you want. For now lets just press
Apply. Yet another windows comes up.

5. In the WalkApplyDialog window check the
options and change values as seen on picture
below right. These setting will make a walk a
complete walk lasting on step and taking about
a second. Move the slider right and left and

you see how the guy goes about walking.

6. All may seem ok now but before exporting
the OBJ sequence of the walk or run you have
to delete the last frame, in this case the 30th
frame. Why? When you set the Always Complete Last
Step in picture 5 Poser made the last frame be exactly
like frame 1. That’s extra so choose Animation >
Animation Setup. Animation setup window pop up.
Change the Total
Frames to one
less, here 29 and
press OK. Poser
asks for a
confirmation.
Press Ok.

7. The walk
animation
sequence is set
correctly now.
Read further instructions how to insert a prop box on
previous page (step 6) and complete the export.
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Creating a Bryce Scene

Creating a simple walk animation

Follow these instructions carefully. They may look long at first but it’s just the cover all bases in the
Poser-Susanna-Bryce animation process. And relax: many setting are done just once and you can later
change most things without changing the animation parameters discussed below.

1. Create the Bryce scene as usual or use an existing file. Be sure to give some animation time for it.
Let’s put in a girl who runs across the scene. For this you must have create a simple running Poser
animation as described
previously in Poser Animation
Tips. First order of business is to
check that out Poser OBJ files
are OK. To check that import one
OBJ file to your scene. From the
Bryce menu choose File > Import
Object and them choose the
appropriate directory where the
animation files reside. The OBJ
figure mesh (as they are called)
comes to the scene. Note the
square at her feet. It’s the “floor”
cue for Susanna.

At this point Bryce should import
the figure without asking for the
texture files you may have used
with the Poser figure. This is very
important! If Bryce cannot find
the texture, bump maps etc. right
away on the same directory as
the OBJ files Susanna will fail. To
make things simple just copy all files in your Poser directory c:\Poser4\Runtime\Textures\Poser 3
textures and c:\Poser4\Runtime\Textures\Poser 4 textures to your designated Poser animation directory,
the directory where you have all the OBJ files of your animation.

2. Ok so your Poser figure came in with all the textures and materials. Often they are slightly off base
and you have to adjust them to
look good. Let’s say we like the
runner but Ambience and
Diffusion must be tweaked. We
also want her hair to use a Bryce
material. For easier selection
select the figure and press the
Solo button. The button turns red
and everything except the runner
and perhaps the camera
disappear. Now adjust the
materials to your liking. Make
some part use Poser textures,
other parts like the hair use a
Bryce material.

3. Now comes the part where you
have to be very accurate. The
solo mode being on press the
Tab key. If your are using the
Director’s view the camera should
be selected with the first Tab. I so
press Tab again to get the first
item in the figure. Most often this is the square at the figures feet. When you have the very first item
selected start tabbing more. After each Tab make a note of the order of “parts” in the figure: The square
is the first, trousers are second, belt is third, ..., flesh is sixth, … and hair last at 19th position. Susanna
needs to know these numbers and you’ll give them her them later.
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4. Now that the part ordering in
the figure is done press the solo
button to get the normal mode
back on. In this example we want
basically two materials 1) the
poser figure materials with
ambience and diffusion tweaked,
and 2) the hair material. Now
create two new boxes (see
picture 6). They will be the
placeholders of those materials
that Susanna will use on the
imported Poser figures. They can
be situated anywhere and won’t
show up in the Bryce animation
unless you want them to.

By the way: the materials boxes
must be the last objects in the
scene. Otherwise Susanna will
complain. We’ll get back on this
at paragraph 12 later.

5. Now select again the Poser figure and go into solo mode (press the solo button so it turn red). Tab
once again a few times until you get to the flesh part. The flesh selected press Ctrl+Alt+C or select copy
material from Bryce drop down menu Edit > Copy Material. The material is copied into Bryce memory.
Select solo mode off and select the first of the new boxes. It selected press Ctrl+Alt+V or select from
Bryce drop down menu Edit > Copy Material. The first box will now have the same material as the flesh.
Most often the material is the whole texture & bump map for the Poser figure, shoes, belt, etc. not just
the flesh.

You probably guess that now you have to repeat the same procedure for the hair. Well, no since we want
hair to have a brand new Bryce material. So select the second “material box” and select any material
from Bryce’s material lab by pressing the “M” button.

6. When both materials are set make them hidden. Press the “A” button next to the box and check
Hidden on. Don’t check anything else. Give both materials a name xmat1 for flesh and xmat2 for hair.
The name has to start with xmat for Susanna to know that this is a Poser material copy. Don’t do any
Linking or Animation changes here. Do not use any commas, empty spaces, etc..; use just simple
namers with letter from A-Z and numbers. The size and placement are not important as they will not be
used for anything.
If you want to animate the
material please do so in the
material lab as described in Bryce
manuals. After you get used to
Susanna you’ll find again the
fantastic potential of Bryce’s
material capabilities. These all
can be used with Poser imported
animation! Horror movie
afocionados may want to
experiment how to create
apparitions and how to make
vampires decompose to dust.

7. Now with the material set we
don’t need the Poser figure so
delete it. You may want to save
the file should you want return to
these settings afterwards. Now
you need to create a placeholder
for the runner and a trajectory for
it. Create a 2d face (a square).
Actually any Bryce primitive will do but it’s thickness (size Y) has to zero. Give the square an unique
name, we’ve used “runner”. The name should only consist of letter A-Z and numbers. Don’t use commas,
spaces, punctuation, etc. yada, yada, yada! Also make the square hidden.

8. Now you should make the animation trajectories for the square, our Poser placeholder.
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When creating walk trajectories
make the box hover somewhat
above ground. Susanna will
adjust the trajectory so that it will
follow contours of the ground. If
your ground is flat then forget
that: you can land it there yourself
-this will speed animation
somewhat.

These instruction have explained
how to create one object with
distinct materials and animation.
Susanna allows of course for you
to create as many characters as
your Bryce can handle. With
128MB we’ve found that even 50
characters work.

You can also have multiple Poser
figures in one OBJ file sequence.
It if easier to create the animation
part (shaking hands, sword duels,
etc.) in Poser.

When creating animations such as walks or runs timing is paramount. How far in Bryce world does your
Poser figure walk in ten seconds? If too much distance is covered the ground slides as the Poser figure
runs or walks. Too short a distance makes the walker/runner slip all the way! Experimentation and testing
is needed as well as careful planning

9. Most things are set at Bryce side so AT LAST we get to start the Susanna program you paid your hard
earned cash for. Since Bryce takes up most screen real estate
minimize Bryce for a moment and double click the Susanna icon.
Then restore Bryce. Susanna is an “allways on top window” so Bryce
won’t cover it. The first order of business is to create a new “project”
for out simple walk. At this point the Susanna main screen may say
Can’t find all Bryce Windows, but don’t worry about that for the time
being (Bryce needs to be in default window size before Susanna can
work).

10. From the Susanna window choose Project > New. A dialog box
comes up and give a new project name, say, running and press OK.
Then choose Menu > Do Bryce Animation. Window Animation setup
comes up. In the windows you have many edit field that are discussed
below. Note that Susanna uses the Enter -key to move from next
field. Down Arrow and Up Arrow work also but Tab will not work. We
like it that way!
Start/end frame in Bryce
Enter 0 and 9999 to these fields.
This tells Susanna that the runner
will appear throughout the
animation (unless your are doing
a very long shot of over 9999
frames). If you put, say, 10 and 20
the runner would suddenly appear
at frame 10 and just as suddenly
disappear after the 20th frame.
Import OBJ name
here you put the name of the
object file sequence you created
and exported with Poser. Recall
from chapter Creating a Poser
File Animation Sequence section
10 the file name you used in
export. Let’s say your file
sequence is named run_1.obj,
run_2.obj, run_3.obj etc.. In this
case put run*.obj to this field. The
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“*” is important because it tells Susanna that you have a file sequence with many files. You can use
the”F” button to select the file.
OBJ center position
This tells Susanna where the “square” is in the imported figure. Often it is the first so put 1 here.
Initial frame
Put 0 (zero) here. This tells Susanna use the first available obj file of the file sequence. So the first
imported OBJ would be run_0.obj. Should you put, say, 4 Susanna would import from run_4.obj
onwards. This parameter comes handy when you have two runners using the same animation file but
both running at different order. Take a look at picture 10b.
OBJ follow parent object
The parent object is the box size 10 you created and made a trajectory for. Since it was namer runner
put runner in this field.
OBJ use material from object
Her you should tell which parts of the object use which material. The entire object will use the material in
box named xmat1 and hair will us the material from xmat2. So put in 0-xmat1, 19-xmat2. The numbers
correspond the the order of appearance of parts in the imported figure. 0 means the whole object, 1 is
often the cue square, hair comes often last. It is also important that you should give the whole object
material first and other parts after it. Don’t forget the comma between and “-” -separator. You can enter
as many settings that fit in the field (it’s a rather long field). Different parts can use same materials. If you
leave this field empty Susanna will use the figure material as it is imported to Bryce. For simply textured
figures such as skeletons it is often sufficient.
Drop levels
This tells Susanna whether you want the figure trajectory to conform to ground below. If you have a
walker or runner put 1 here. If you have a superhero flying across the sky leave it to zero. If your
trajectory already is following the ground set this to zero as it will speed up animation.
Keep on repeating object
This is default at the moment. What it means that even if you have Poser object file sequence of just 30
moves worth of one second but your Bryce animation requires to have a ten second walk Susanna will
repeat and repeat the file sequence for those 10 seconds.
“Save” and “Open” dialog names
Susanna needs to know the window titles for the common dialog windows. If you have an english
language windows version leave these fields to Save as and Open. Otherwise put in you own language
equivalents.
Render height & width in pixels
Susanna makes use of most of the setting in Bryce’s
settings but these two must give.
Render frames
This tells Susanna which animation frames you want
to render. If you are doing a 100 frame animation put
0 and 100. If you are creating a long animation you
can break the animation in parts. Maybe even use
multiple computers to render parts to save overall
time.
Susanna makes Bryce render the animation to a bmp
file sequence - not an AVI file. You can later
recompile the individual BMP files to an AVI movie
using your favourite AVI/Mpeg compiler. Adobe
Premiere and just about any movie editing package
have this feature. Internet has numerous free utilities
for this purpose. The BMP files sequence is saved a
A0.BMP, A1.BMP, A2.BMP, … etc. to the directory
where your Poser generated OBJ files exist.
Render destination directory
The directory where the BMP files will be generated.

The Animation set up window has File and Edit
drop-down menus. The File menu is used to
manipulate project setting. Better leave it unused until
you become familiar with with all features. Edit menu
is useful. With it you can copy all fields visible, add a
new item and paste fields to the new item. The listbox
on top right lists all existing items. In this example we
have just one, but in other project you may have
numerous items these. Clicking on the list gets the
item details to the window fields.
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Next follow some more detailed
discussion on other option if
you’re in a hurry skip directly to
paragraph 11.

Take a look at picture 10d of an
animation of 45 skeletons and
how they have been set up.
Notice the listbox has many
items. Notice that all the items
use the same OBJ file sequence
JUO*.OBJ in another directory.
Also take a look at the Bryce file
(10e). Notice that it has just four
squares. Where are the 41 other
squares? Well, in Susanna you
can make some object repeat at
a different place. Take again look
at picture 10d. Notice that OBJ
follow parent object is ROBO5-9.
That means that this particular
item does not have it’s own
square but rather uses the trajectory of
ROBO5 box nine frames behind. You can have
either behind (-) or in front (+). If there is no
frame behind nothing will show up.

11. Whew … was that a long description. Sure
hope you read it. Okay. Now is the time to
move on. Press Esc. We won’t continue just
yet. You must first save your Bryce file! During
rendering Susanna will alter the Bryce scene
so you must be able to return to current state if
you want to make changes or something got
messed up.
While Susanna is forgiving for many errors she
just won’t work with wrong data. For example if
you have named the box as runner but in the
Animations setup windows it is runer nothing
good will happen! So double check spelling
and other details again.

12. Here are some do and don’t of working with Susanna.
Material boxes
They must be hidden and named. They must not be grouped since Susanna polls their values during the
animation! They must be the last objects in the Bryce scene. It is often good practise the make them into
a family so you can select all of them easier. There’s a tip on making them last easier and some caveats
in next chapter Bryce Animation Tips.
Poser squares
They must be hidden and their thickness
must be set to 0. They most not be grouped
or locked.
General Bryce appearance
For the duration of the animation Bryce must
be set to default document setup. So choose
File > Document setup click Default on top
right and press the check on bottom right.
This is very important.
a) the Edit mode must be on
b) an empty space must be exists above
Susanna window. Susanna uses this space
for mouse clicks that set focus on Bryce.
c) Susanna window must not be over
camera/director and generally not over the
Bryce workspace.
d) the Alternate VCR mode must be on.
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e) the Object Selection palette must be on (not Time selection palette).

Susanna relies on many things while rendering goes on:
a) don’t run other program that could interfere with program execution. Screen savers and virus detaction
program will slow and hinder program execution unnecessarily. The Bryce view should clear of any other
popup windows except Susanna’s main window.
b) Bryce nano-view auto-update should be set off. If set on problems & render times will be multiplied. So
set it off.
c) General Windows appearance must be “standard”. That means that Windows taskbar (taskbar is the
one with “Start” button) must be at the bottom of the screen and not up or at sides.

13. Now we can really try out the animation. Click some object in Bryce scene and then in Susanna
choose Menu > Try to find Bryce. The annoying message Can’t find all Bryce Windows should disappear.
Then choose Menu > Do Bryce Animation. Window Animation setup comes up. If this is your first try go
easy and put 0 and 5 to Render frames
and Press OK. We’ll render just six frames (0-5).

A list comes up. Choose Re-calculate path settings and press OK (the list items are discussed in Bryce
Animation Tips). Susanna will now gather data where everything is and should be during the animation.
The animation will be run without Poser figures but hang in there. Then a new prompt comes up: press
OK.

Yess!!! Now the the funny part begins. The screen changes, menus pop up and go off. It’s just Susanna
pressing buttons, selecting menus like a phantom gotten loose on your keyboard. But if all goes well you
will notice that an animation is really happening.

Bummer!!! If all goes to a fine mess blame it on this being the 13th paragraph. No really, something
must be wrong with data given to Susanna’s dialogs. If Susanna appears to get stuck press Ctrl+Alt+Del
and shut down Susanna the Windows time honored hard way. Luckily Susanna can be interrupted in this
unsavorily way without the program or data getting too much mucked up. Then you can revert to a
previously saved Bryce scene and try again with correct data this time around. Why anything like this
should happen? Read about it in next chapter How to minimize problems.

When the dust has settled and animation appears to have gone OK and finished you should have a nice
selection of BMP files a0.bmp, a1.bmp, a2.bmp and so on in the render destination directory. Then use
your favourite AVI/Mpeg or whatever program to compile them to a full-fledged movie which will be the
envy of George Lucas et al!
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Bryce Animation Tips & Techniques

Object trajectories

A trajectory is a list of saved positions of you animated Poser figures. Before an animation can begin
Susanna retrieves each square position where it is located during the animation timeline.

You can edit manually the trajectory locations by choosing from Susanna main window Other > Edit
Susanna table > Current path table. A spreadsheet comes up where you can edit individual points.

Walking through a fog

When creating walker animation you often use the feature “Drop to ground” (you set Drop levels to 1 in
Animation setup window). But if you put a fog sphere just over the ground the walker walks on the fog
sphere not through it. There is a an easy solution: create the scene with out fog spheres. Then let
Susanna recalculate all trajectories. When that is done and program asks if you want to continue answer
no. Then make any changes such as adding fog elements etc. and save the Bryce file and do the
animation again. When Susanna asks if you want to recalculate all paths select Use current trajectory
setting. Susanna will then animate with trajectories that go right through any obstacles.

Poser figure placeholder, the “square”

A bryce scene has to have square (thickness Y 0) for all the Poser figures that are imported. You can just
as well use a flat circle but it is often easier to see which way a square is pointing. Susanna keeps a list
of all of them. You can manipulate the list in Animation setup window. You can also edit them in a
spreadsheet. Choose from Susanna main window Other > Edit Susanna table > Current object table.

Material boxes

These hold the material information for Poser figures and their parts. The material boxes should not be
locked or grouped but it is often good practise to make them into a family for easier selection.

Another good practise is the put them neatly next each other and name them consecutively xmat, xmat2,
xmat3, etc. The name must have an “xmat” name.

They must be the last objects in the scene. If you’ve added other objects after creating the material
boxes do this:

1) Select all material boxes (a couple of clicks if they are a family -but don’t use a group!).

2) Press Ctrl+C to copy them into Bryce’s memory (don’t do a duplicate operation -it’s often messier)

3) Delete the selection by pressing Del! They are gone now (but not forgotten).

4) Paste the selection by pressing Ctrl+V. The boxes come back. They are now the last or newest
objects in the Bryce scene. By the way the copy and paste have menu equivalents in Bryce hidden top
drop-down menu.

5) All is well now but there one glitch or should we say feature in Bryce. When you copy and paste (or
duplicate) items Bryce re-names them. So if your material boxes were named xmat1, xmat2 and xmat3
now they are named xmat2, xmat3 and xmat4. Bryce has re-named them and messed things up! Be sure
to give the boxes their old names xmat1, xmat2 and xmat3 or whatever they were.

How do I delete and otherwise manipulate projects

From Susanna main window choose Project > Manage projects. A spreadsheet comes up. You can
change the names, delete project (press Del on the project) and select projects. When you exit the table
Susanna will ask if you want to select this project.

The project table has also filenames which you should not edit. These refer to project path table and
object table files.

I want to cancel an on-going animation, how do I stop it?

Wait until next Bryce rendering dialog comes up. Then press the “X”, cancel button and cancel the
operation. You can also press Esc. Wait a few seconds until Susanna reports that animation as been
interrupted and press OK a couple of times.
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If all appears stuck just press Ctrl+Alt+Del to cancel Susanna alltogether.

How to minimize problems & speed up animation

Here are some tips which help Susanna in making an animation:

Apply the usual Bryce rendering tips

These include turn off nano view autoupdate. Also make sure no unnecessary other programs are
running (virus checkers etc.).

Note! Sometimes Bryce goes into a non-responsive mode when you use another program in the
foreground such as Susanna. Bryce looks OK and appears to have fous but won’t accept keyboard entry
(tabs, Ctrl+Alt+E, etc.). This will prevent Susanna from working. To avoid this situation just prior to
starting Susanna rendering (when you are still in the Re-calculate all trajectories window) click some
object in your Bryce scene. Then press Tab with out keyboard a couple of times. Bryce should select
next object with each Tab press. Bryce should now be out of the non-responsive mode and you can
continue with Susanna operation.

Group and lock objects

If you have a huge Bryce scene with hundreds of objects group and lock those that are not connected to
the square figure placeholders. Don’t group or lock the Bryce square placeholder, nor the material boxes.
Remember that even though other objects are grouped and locked Bryce still applies all own animation
changes on them. Grouping and locking just makes it harder for you to accidentally delete or move the
object. Furthermore before Susanna starts the animation process it cycles through every object in the
scene. Having five “free” objects and perhaps one humongous group with hundreds of objecs takes a lot
less time to go through.

Have plenty of free diskspace

Free disk space helps and keeping your disk tidy by running de-fragmentation programs on a regular
basis.

Leave keyboard and mouse free

For the duration of animation don’t use the keyboard or move mouse around. Susanna uses keyboard
and mouse herself during the animation.

Turn off screen savers

Susanna relies that Bryce menus stay on on during the entire rendering process. If you leave your
computer running for a long time turn off monitor to prevent screen burn.

When things go wrong restart Windows and Bryce

If Bryce hangs Susanna will go down with it. Often hung jobs can be run with better luck restarting
Windows afresh. Then check which frames went ok and continue rendering job from next frame.

How Do I make My Poser Walk a Winding Path

The Bryce Way

Link your square to a path object.
Link also a sphere to the same
path object. Then make the
square track the ball. You square
can be constrained to the path or
linked a hidden object which is
contrained to the path. The latter
way is often easier to handle.

At the beginning of the animation
timeline the sphere should be
constrained to 5% of the path
position. The square should be at
0%.

At the end of the animation
timeline the sphere should be
constrained to 100% of the path
position. The square should be at
95%.
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This way the sphere is always leading the square.

The Poser Way

Create a winding path in Poser. Also create the square. Make your poser walk the path it and export the
OBJ file sequence. In Bryce the Bryce square placeholder should remain still since the OBJ animation
file sequence already contain a winding walk.

I’ve imported two Poser figures for animation but their sizes don’t match in Bryce

Create and size both posers in Poser in the same scene.
Let them have both their own squares. Export them
individually (check only the relevant poser and square in
export item list).

For example there is a low-res male and a hi-rez female
in the picture on the right. I they were in separate poser
scenes they would import to Bryce as midget-man and 7
ft she-woman!

Can I use some other file prefix for animation sequence
files; other than “A”

Sure. When you are in the Animation setup window
select Other -dropdown menu and File sequence prefix.
Enter any letter from A to Z.
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Creating a 2D picture that shows another animation

Among other graphics primitives like box, sphere, etc. Bryce has a flat square where you can add a
picture. Unfortunately there is no simple way to put another animation there, just a static bitmap. With

Susanna this is possible however. You can have
up to 30 “movie screen”. Here’s how.

1) Create a Bryce scene with Poser figure
placeholder. what is different from usual squares
is that this time around the square is a 2D Picture
object (a “leo”) and it is not set to hidden. You
should create these object as first objects that
have a bitmap texture or bumpmap. Also assign
some BMP file to each 2D picture object. It does
not matter which BMP since another will be used
at render time. Take a look at picture 4 on this
page. Our scene on left has 4 “movie screen”,
three are flat 2d object and the “Robo5:x” is a
cube object. They have all been assigned a
unique bitmap. The Robo5:x the bit map is a
material texture. If you use a material texture you
should have “:X” attached to it’s name in Bryce
and in Susanna.

2) When you set item details at Animation setup
window in Susanna these fields have special
meaning:
Import OBJ name

Here put a name of you animation BMP file sequence. Pretty much like
you set OBJ file sequences. In this example a BMP animations
sequence of files B0.BMP, B1.BMP, B2.BMP, .. etc. exists on directory
J:\OMAT\SILVER. These are played of the 2D faces.
OBJ Center position
Since a 2D picture object is just one piece put zero here allways.
Other input fields behave similarly to regular OBJs. You can use
materials to set special effects, but most often materials are not used.

If you want to have static 2D picture objects in addition to animated
ones you must define them like they were animation placeholders: the
animation BMP file sequence simply have just one file. This is because
Susanna takes over 2D picture file handling from Bryce at runtime.
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Importing Bryce and Poser animations to real life movie footage

A sample explains best how you can do …

1) Import your digital or analog video to your computer. To get best results you should use good quality
digital video. If your footage is grainy or has artefacts the combined Bryce/Poser/Video will not look
premium. Also digital/analog video often has interlacing. You can minimize this using de-interlacing by a
number of utilities such as Avery Lee’s fine VirtualDub program.

Also your AVI/Mpeg etc. video should be exported to a BMP file sequence. There are many commercial
programs and free utilities on the net that can convert your AVI a series of BMP files and vice versa. So
you should convert your AVI movie to a series of 24 bit BMP files P0.BMP, P1.BMP, P2.BMP. It is
important that the BMP files are “24 bit” or 16.7 million colors as Bryce and Susanna use this color
format.
Above video (btw. that’s the real-life
Susanna) has been shot with a stationary DV
camera. The camera does not move or pan to
make things easier.

2) Create a Bryce scene with the square plate
and all as described earlier in this Susanna
manual. Make sunlight and other light
sources mimic the actual video. Position the
camera or directors view so that the view
mimics the real video. What is different is that
just about every other object in is colored
bland white.. A stretched cube represents the
grey light pole, a ground plane is the
pavement and a squashed cylider mimics the
grassy knoll (grassy knoll? now where did I
hear that hmm??). All have been set so that
when rendered a blank white picture appears.
Use the material editor and set Ambience and
Diffusion so that all shadows and form appear totally
white (figure 2b).

The whole Bryce scene is actually set to cater to the
skeletons shadow. When the skeleton walks past the
pole it’s shadow should reflect as realistically as
possible. So there is no need to create the house on
the back or trees. If you want reflections add objects
with reflecting materials.

You’ll probably have to work of making the object
materials white just enough them you disappear when
rendered but not too much lest the skeletons shadow
not appears if ambience is set too high (figure 2c).
Round objects often need to be changed to boxy
types.
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When Susanna imports the skeleton it looks
OK and it’s shadow shows up good too.

You may of couse add many posers to the
scene as desribed earlier.

3) The process of creating other animations
parameters involve the same steps as
usually. Go to the Animation setup dialog
and enter the fields as desribed earlier. One
important thing: select render size exactly
the same as your actual video. Your
rendered Bryce scenes must be same! So if
your video frame size is 320x240 then Bryce
render must match those.

Then start the animation process with
Susanna. When the animation is finished
you have a series of bitmap files A0.BMP,
A1.BMP, ... etc. on your designated render
directory.

4) Next we need a “mask” render of all posers. Click
the render options down arrow (figure 2c) and select
Mask Render.

Then start again the animation process with
Susanna just like in paragraph 3 above. Oh .. a
couple points are different. There’s a drop down
menu Other. Select This is a mask render. A
checkmark comes next to the selection (btw if you
have just one poser in the scene this selection is not
needed). Also select File sequence prefix. A dialog
comes up; put M (as in mask) and press OK. Now
Susanna will create animation files M0.BMP,
M1.BMP, M3.BMP, … and so on. Otherwise the
render files in paragraph 3 would be overwritten.

5) Now we have the video footage as P0.BMP,
P1.BMP, … etc., a Bryce render files A0.BMP,
A1.BMP, … etc. and a mask render sequence
M0.BMP, M1.BMP in our render directory. To
combine them to create the final sequence
from the main Susanna Windows select Other
> Combine renders. Put filex prefixes as
shown in picture 5. Shadow factor tells how
dark the shadow should be. Just accept 50.
100 would be probaly too dark a 10 too light
for most situations.

When you’ve pressed OK and the whole
rigmarola of creating animations is finished you have a nice set of BMP files: Z0.BMP, Z1.BMP, Z2.BMP
etc.. Compile this with your favourite AVI/Mpeg creator into a great looking F/X movie and be the next
Steven Spielberg!

Moving camera

If you use a moving camera the “camera” in your Bryce scene must replicate the movements. It is difficult
but doable. Examine closely how much many frames each move takes and then replicate the moves with
your Bryce “camera”.

How to get Bryce objects to my movie?

1) First create the animation like described earlier. Let’s say you you want a Bryce a ball and a torus in
the scene with the skeleton. Create the torus and ball and assign a non white material. Then do the steps
1-4 to create the BMP files: A*.BMP, M*.BMP and P*.BMP. Next we need to create a mask file sequence
for Bryce objecta (torus and ball).
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2) We now need to create a mask render of
just the torus and the ball. Select the torus
and then select options as in picture 2. Mind
you, we are not using Susanna here. Make
sure the file sizes (height and width) must
match the other BMP files created earlier. In
this example we have used 320 x 240. If you
use other size you can set the document
size also in File > Document setup.

3) Then select File > Render Animation.
Select Format BMP Sequence and File
location to same as the other BMP files
(figure 3) and then press the check mark.

Bryce usually creates the masks pretty fast.
After it’s done you have mask0000.bmp,
mask0001.bmp, etc. in your designated files
directory. Make sure it’s the same
directory as the other files.

4) Then from the main Susanna
Windows select Other > Combine
renders. Put filex prefixes this time as:
- Bryce/Susanna BMP files prefix: A
- Bryce/Susanna BMP mask files prefix:
M
- Background files prefix: P
- Combine result BMP mask files prefix:
Z
- Extra Bryce mask BMP files: mask

… and press OK. Then you will have a
nice set of BMP files: Z0.BMP, Z1.BMP,
Z2.BMP etc.. Compile this with your
favourite AVI/Mpeg creator into a super
looking F/X movie and James Cameron
will consider hiring you for his movie
project Titanic II: Return of Jack!

What could go wrong

Remember each file sequence must be same
size and have 24 bit color depth. Each file
sequence must have same set of file, ie. you
can’t have mask file 1-50 and scene files 1-100.
If the skeleton appears to slip either shorten or
lenthen his path and try steps 1-5 again.

Susanna Page 17

2

Torus and ball are selected

3

4



3d Motion Blur

What is Motion Blur

Bryce renders every image crystal sharp. This is true for every frame of animation resulting in jumpy and
unrealistic motion. In single pictures objects should look moving fast just appear to “hang in the air”. So
even when creating single pictures applying motion blur adds realism.

When a moving object is captured on film or digital
video it is blurred somewhat. Take a look at the
pictures below. The picture on the left has motion blur
but the one on right does not. The picture on the right
is sharp but you cannot tell from the picture whether
she is standing on one foot or running. With motion
blur it is immediately evident that she is running. The
motion blurred image is blurry but that is how she
would look if the frame was a still from a movie or
paused video tape segment. Check the effect by
using the pause key of your VCR in the middle of a
action packed scene. The action scenes are blurry.

The blur effect is variable. The third picture has half of
the blur effect. The picture is more detailed. Susanna
makes 3d motion blurred of your scene. The “3d” here
means that only those parts that actually move are
blurred in reletion to their speed and direction. So if
your scene has static objects (backgound sky,
mountains farther away) they remain as sharp Bryce
can render them. On the other hand if you have a fast
moving camera flying over scenery most everything
will blur unless they are static in relation to camera.

Are there any disadvantages to motion blur? We’ll
one thing for sure: render times are often quadrupled

or more depending on the scene and how good a blur you need. Unfortunately there is
no good way around this.

Can I generate still picture with motion blur?

Of course. A still is just a BMP file from your animation. The blurred girls on this page
are compiled from an 8 BMP file long and 4 BMP file long “movies”.

How to create motion blurred scenes?

Creating motion blur into your scene requires patience and planning ahead. For the
scene to be motion blurred adequately you must render the scene in slow motion. So if
you have a scene of girl running past camera it takes about two seconds. So if you are
creating a 25 fps (frames-per-second) movie you need 25 x 2 = 50 BMP files. When
adding motion blur you must at least quadruple that so you need 200 frames. If the
action takes a lot of screen real estate go even further and use 8x motion blur and 400
frames. This is the way it’s done in big-budget movies productions with 3d effects:
hundreds of computers rendering lots and lots of frames.

So to create an animation with motion blur do everything in 4x or 8x slow motion.
Nothing really is different using Poser, Bryce and Susanna. In the end you get a series

of BMP files. If you need to do motion blur you need more frames or BMP files which Susanna will cook
into motion blurred movie segment.

Here’s an example: Lets say you have created a 400 BMP file of a girl running past the camera. The
BMP files are a1.bmp, a2.bmp, a2.bmp, ..., a400.bmp and they are all in directory c:\susanna.

• In Susanna choose Menu and Do Bryce Animation. The Animation setup window comes
up. Make sure that Render destination directory is c:\susanna\ (in this example). Susanna
needs to know where the rendered BMP files are. Then press Esc because we don’t want
to generate the files again. We just wanted to check the directory name.
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• From Susanna main window
choose Project and Motion blur.
Window Apply motion blur
comes up.
File sequence prefix
Since our files have A for name
prefix (they are a1.bmp, a2.bmp,
a2.bmp, ..., a400.bmp etc.) here
is A.
Sequence steps
Here we have 8. So our 400 files will be compressed into 400/8 = 50 motion blurred BMP
files. 30 is maximum.
Start sequence
This is the number of intial BMP file. Since our files are a1.bmp, a2.bmp, a2.bmp, ...,
a400.bmp etc.) here is 1.
Save as sequence name
If you have Z here the 50 BMP files will be named z1.bmp, z2.bmp, ..., z50.bmp. The new
files will be in the same directory as original files.
Apply blur
When creating a motion blur check this on if your sequence looks “jaggy”. Most often this is
required if your Sequence steps is less than 8.
Don’t do blur, just compile
Having this on disables any blurring.

Lastly press OK. The pocess takes some time but is a lot faster than rendering. As a result you should
now have a sequence of files z1.bmp, z2.bmp, ..., z50.bmp. Compile them into an AVI, Mpeg or
whatever. Check out how it looks like and come back and tweak the settings some more to see more
how a blur is created.

What is the Use other sequence button used for?

Normally Susanna will use a sequence of files generated using Bryce and Susanna. Susanna always
numbers them a1.bmp, a2.bmp, a2.bmp, ..., a400.bmp etc.. But if you create a BMP sequence with just
Bryce or Poser or any other 3d sofware such as Vue you often get a file sequence something like
test0001.bmp, test0002.bmp, test0003.bmp, … and so on. If you press Use other sequence you are
prompted for an alternate sequence. The sequence uses a C sprintf style “stencil” but if you are not a
programmer just render the files as test0001.bmp etc. and use c:\susanna\test%04d.bmp here.
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How Does Susanna Work

The operation in a nutshell

Susanna is basically a macro program that sends Bryce commands what to do. It also keeps tabs on
what’s happening so it can send next commands when Bryce has don it’s current chore. The commands
Susanna sends Bryce are stored in script files.

Most often Susanna sends Bryce keyboard shortcuts such as Ctrl+Alt+E which brings up an Object
attributes dialog window. For those actions that have no shortcut Susanna uses the mouse to press
buttons and makes things happen.

While all his goes on Susanna keep looking at Bryce windows to find out if the her last command has
been executed by Bryce. She often looks at certain pointers on the screen to figure out that. For example
when she presses the “Solo” button she waits it to get red. if nothing happens, she tries again for a few
times. For this reason you should not change views, switch to another program etc. while animation is
going on.

The Susanna Script Language - open source

Susanna scripts are stored on PRG files. The programming language resembles Xbase language which
is used in many programs. Susanna also
used DBF files common to dBase,
Microsoft Foxpro and others.

The Susanna script files can be edited
and recompiled to add features and make
changes. This feature is open only to
progammers who know what they are
doing. So there: you have been warned!
Don’t mess things! Ok … ok. Here’s a
quick preview. In Susanna directory
there’s a script source file bryce1.prg. It
contains for example the creation of
Susanna main windows and menus. Let’s
say you you don’t like the default size and
want to set to something else. Then you
can edit the parameters in line
ikku=winnew(...). Later you can recompile
the source so that the Susanna will work
with new settings. To recompile
bryce1.prg open a dos box and run
mikkocom bryce1 in the Susanna
directory.

Who needs this functionality, after all only techie nerds can make use of it? Well the point is to provide
you, our honored customer, a way to add & change the program to suit you. If a feature is missing or
implemented to your disliking it can be changed. You won’t hit a brick wall. You can get a third party to
make necessary changes or do it yourself.
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